Project

General

Profile

Actions

Task #11855

closed

[grab me] Setup lemmy in k8s

Added by Nico Schottelius 11 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Start date:
07/07/2023
Due date:
% Done:

100%

Estimated time:
40.00 h (Total: 40.50 h)
PM Check date:

Subtasks 1 (0 open1 closed)

Task #11861: get an ungleich k8s cluster or create an own, for example using k3sClosedPeter Schwindt07/07/2023

Actions
Actions #1

Updated by Peter Schwindt 11 months ago

  • Subject changed from [grab me] Setup lemmy in k8s to Setup lemmy in k8s
  • Assignee set to Peter Schwindt
Actions #2

Updated by Peter Schwindt 11 months ago

maybe helpful:
Actions #3

Updated by Peter Schwindt 11 months ago

  • Status changed from New to Seen
  • Estimated time set to 40.00 h
Actions #4

Updated by Peter Schwindt 11 months ago

  • Subtask #11861 added
Actions #5

Updated by Peter Schwindt 11 months ago

  • Status changed from Seen to In Progress
Actions #6

Updated by Peter Schwindt 11 months ago

Tried to go the way to first set it up using docker-compose, but there seems to be an issue with not having rustfmt and / or a too old version of rust (?) installed:

167.1 error: failed to run custom build command for `lemmy_utils v0.18.0 (/app/crates/utils)`
167.1
167.1 Caused by:
167.1   process didn't exit successfully: `/app/target/debug/build/lemmy_utils-87c80cd323807c89/build-script-build` (exit status: 1)
167.1   --- stderr
167.1   Error: FileRead { file: "translations/email/en.json", source: Os { code: 2, kind: NotFound, message: "No such file or directory" } }
167.1 warning: build failed, waiting for other jobs to finish...

(even when moving one release back...)

Actions #7

Updated by Peter Schwindt 11 months ago

<flips table> unlocking

Actions #8

Updated by Peter Schwindt 11 months ago

  • Subject changed from Setup lemmy in k8s to [grab me] Setup lemmy in k8s
  • Status changed from In Progress to New
Actions #9

Updated by Peter Schwindt 11 months ago

  • Assignee deleted (Peter Schwindt)
Actions #10

Updated by Nico Schottelius 5 months ago

  • Status changed from New to Closed
Actions

Also available in: Atom PDF