How to configure Arista switches » History » Revision 14
Revision 13 (Nico Schottelius, 05/21/2020 05:02 PM) → Revision 14/15 (Dominique Roux, 04/22/2021 09:29 AM)
h1. How to configure Arista switches
{{toc}}
h2. Saving your changes
If you don't enter write at the end, everything is lost after reboot.
<pre>
write
</pre>
h2. Entering conf mode
<pre>
enable
conf
</pre>
h2. Setting password
<pre>
username admin secret <passwordhere>
</pre>
h2. Setting name
<pre>
hostname <NAME>
</pre>
By default set it to *switch-placeX*. While the placeX part is indeed redundant, it is necessary to be able to distinguish switch1.place5 and switch1.place6.
h2. Creating a VLAN
<pre>
vlan <ID-OF-VLAN>
name <NAME-OF-VLAN>
</pre>
h2. Putting a port into a untagged vlan
<pre>
interface EthernetXX
switchport access vlan YY
</pre>
h2. Creating a port channel (= LACP = bonding)
* go to the interface that you want to be in the port-channel
* configure it
<pre>
interface EthernetXX
channel-group XX mode active
</pre>
h2. Creating a port channel over multiple switches using MLAG
<pre>
interface EthernetXX
channel-group XX mode active
interface port-channel XX
mlag XX
</pre>
And if you want to have tagged/trunk port:
<pre>
switchport mode trunk
</pre>
If you want to have untagged connections to be automatically tagged:
<pre>
switchport trunk native vlan <VLAN>
</pre>
If you want to allow fallback of lacp:
<pre>
port-channel lacp fallback static
port-channel lacp fallback timeout 20
</pre>
h2. Upgrading a switch
* copy the image from usb to flash
* change the boot config
* don't forget to write
* reload
<pre>
copy usb1:/EOS-4.14.4.swi flash:/EOS-4.14.4.swi
configure terminal
boot system flash:/EOS-4.14.4.swi
show boot-config
write
reload
</pre>
h2. Configuring MLAG
* Create a port channel for communication
* Configure the mlag over it
* Assuming the switches are connected by ethernet 47 and ethernet 48
* Assuming that the switches use vlan 13
* ZZ = ip suffix of the switch
* WW = ip suffix of the other switch
* mlagdomain = something local
<pre>
interface ethernet 47
channel-group 47 mode active
interface ethernet 48
channel-group 47 mode active
interface Port-Channel47
switchport mode trunk
switchport trunk group mlag-aristas
vlan 13
name mlag-aristas
trunk group mlag-aristas
interface Vlan13
no autostate
ip address 10.3.4.ZZ/24
mlag configuration
domain-id MLAGLOCALDOMAIN
peer-address 10.3.4.WW
local-interface Vlan13
peer-link Port-Channel47
</pre>
h2. Configuring BGP
* XX = ip suffix
<pre>
router bgp 209898
router-id 0.0.0.XX
bgp default ipv6-unicast
maximum-paths 4
bgp listen range 2a0a:e5c0:1:8::/64 peer-group ungleich remote-as 209898
neighbor ungleich peer-group
neighbor ungleich maximum-routes 12000
</pre>