Project

General

Profile

Actions

How to configure Arista switches

Saving your changes

If you don't enter write at the end, everything is lost after reboot.

write

Entering conf mode

enable
conf

Setting password

username admin secret <passwordhere>

Setting name

hostname <NAME>

By default set it to switch-placeX. While the placeX part is indeed redundant, it is necessary to be able to distinguish switch1.place5 and switch1.place6.

Creating a VLAN

vlan <ID-OF-VLAN>
name <NAME-OF-VLAN>

Putting a port into a untagged vlan

interface EthernetXX
   switchport access vlan YY

Creating a port channel (= LACP = bonding)

  • go to the interface that you want to be in the port-channel
  • configure it
interface EthernetXX
   channel-group XX mode active

Creating a port channel over multiple switches using MLAG

interface EthernetXX
   channel-group XX mode active
interface port-channel XX
   mlag XX

And if you want to have tagged/trunk port:

   switchport mode trunk 

If you want to have untagged connections to be automatically tagged:

switchport trunk native vlan <VLAN>

If you want to allow fallback of lacp:

port-channel lacp fallback static
port-channel lacp fallback timeout 20

Upgrading a switch

  • copy the image from usb to flash
  • change the boot config
  • don't forget to write
  • reload
copy usb1:/EOS-4.14.4.swi flash:/EOS-4.14.4.swi
configure terminal
boot system flash:/EOS-4.14.4.swi
show boot-config
write
reload

Configuring MLAG

  • Create a port channel for communication
  • Configure the mlag over it
  • Assuming the switches are connected by ethernet 47 and ethernet 48
  • Assuming that the switches use vlan 13
  • ZZ = ip suffix of the switch
  • WW = ip suffix of the other switch
  • mlagdomain = something local
interface ethernet 47
    channel-group 47 mode active

interface ethernet 48
    channel-group 47 mode active

interface Port-Channel47
   switchport mode trunk
   switchport trunk group mlag-aristas

vlan 13
   name mlag-aristas
   trunk group mlag-aristas

interface Vlan13
   no autostate
   ip address 10.3.4.ZZ/24

mlag configuration
   domain-id MLAGLOCALDOMAIN
   peer-address 10.3.4.WW
   local-interface Vlan13
   peer-link Port-Channel47

Combining (MLAG+nolacp) + (Trunk+untagged vlan fallback)

  • Allow servers to netboot
  • Without LACP active
  • Without VLAN tagging active

Configuration valid for both switches:

interface Port-Channel1
   switchport trunk native vlan 10
   switchport mode trunk
   port-channel lacp fallback static
   port-channel lacp fallback timeout 20
   mlag 1
!
interface Ethernet1
   channel-group 1 mode active

Configuring BGP

  • XX = ip suffix
router bgp 209898
   router-id 0.0.0.XX
   bgp default ipv6-unicast
   maximum-paths 4
   bgp listen range 2a0a:e5c0:1:8::/64 peer-group ungleich remote-as 209898
   neighbor ungleich peer-group
   neighbor ungleich maximum-routes 12000 

Updated by Nico Schottelius over 2 years ago · 15 revisions