Project

General

Profile

How to configure Arista switches » History » Version 11

ll nu, 07/12/2019 08:59 PM

1 1 Nico Schottelius
h1. How to configure Arista switches
2
3 3 Nico Schottelius
{{toc}}
4
5
h2. Saving your changes
6
7
If you don't enter write at the end, everything is lost after reboot.
8
9
<pre>
10
write
11
</pre>
12
13 1 Nico Schottelius
h2. Entering conf mode
14
15
<pre>
16
enable
17
conf
18
</pre>
19
20
h2. Setting password
21
22
<pre>
23
username admin secret <passwordhere>
24
</pre>
25
26
h2. Setting name
27
28
<pre>
29
hostname <NAME>
30
</pre>
31
32
h2. Creating a VLAN
33
34
<pre>
35
vlan <ID-OF-VLAN>
36
name <NAME-OF-VLAN>
37
</pre>
38
39 2 Nico Schottelius
h2. Putting a port into a untagged vlan
40 1 Nico Schottelius
41 2 Nico Schottelius
<pre>
42
interface EthernetXX
43
   switchport access vlan YY
44
</pre>
45
46 1 Nico Schottelius
h2. Creating a port channel (= LACP = bonding)
47 2 Nico Schottelius
48
* go to the interface that you want to be in the port-channel
49
* configure it
50
51
<pre>
52
interface EthernetXX
53
   channel-group XX mode active
54
</pre>
55 4 Nico Schottelius
56 10 Nico Schottelius
h2. Creating a port channel over multiple switches using MLAG
57
58
<pre>
59
interface EthernetXX
60
   channel-group XX mode active
61
   mlag XX
62 11 ll nu
63
# this seems wrong: mlag can only confed on port-channel ?
64 10 Nico Schottelius
</pre>
65
66
And if you want to have tagged/trunk port:
67
68
<pre>
69
   switchport mode trunk 
70
</pre>
71
72 4 Nico Schottelius
h2. Upgrading a switch
73
74
* copy the image from usb to flash
75 1 Nico Schottelius
* change the boot config
76 5 Nico Schottelius
* don't forget to write
77 4 Nico Schottelius
* reload
78
79
<pre>
80
copy usb1:/EOS-4.14.4.swi flash:/EOS-4.14.4.swi
81
configure terminal
82
boot system flash:/EOS-4.14.4.swi
83
show boot-config
84
write
85
reload
86
</pre>
87 6 Nico Schottelius
88
h2. Configuring MLAG
89
90
* Create a port channel for communication
91
* Configure the mlag over it
92 7 Nico Schottelius
* Assuming the switches are connected by ethernet 47 and ethernet 48
93
* Assuming that the switches use vlan 13
94
* ZZ = ip suffix of the switch
95
* WW = ip suffix of the other switch
96
* mlagdomain = something local
97 6 Nico Schottelius
98
99
<pre>
100 7 Nico Schottelius
interface ethernet 47
101
    channel-group 47 mode active
102
103
interface ethernet 48
104
    channel-group 47 mode active
105
106 9 Nico Schottelius
interface Port-Channel47
107
   switchport mode trunk
108
   switchport trunk group mlag-aristas
109
110 7 Nico Schottelius
vlan 13
111
   name mlag-aristas
112
   trunk group mlag-aristas
113
114
interface Vlan13
115
   no autostate
116
   ip address 10.3.4.ZZ/24
117
118
119 1 Nico Schottelius
mlag configuration
120
   domain-id MLAGLOCALDOMAIN
121
   peer-address 10.3.4.WW
122 8 Nico Schottelius
   local-interface Vlan13
123 1 Nico Schottelius
   peer-link Port-Channel47
124 8 Nico Schottelius
125 6 Nico Schottelius
126
</pre>
127
128
h2. Configuring BGP
129
130
* XX = ip suffix
131
132
<pre>
133
router bgp 209898
134
   router-id 0.0.0.XX
135
   bgp default ipv6-unicast
136
   maximum-paths 4
137
   bgp listen range 2a0a:e5c0:1:8::/64 peer-group ungleich remote-as 209898
138
   neighbor ungleich peer-group
139
   neighbor ungleich maximum-routes 12000 
140 1 Nico Schottelius
</pre>