Project

General

Profile

How to configure Arista switches » History » Version 13

Nico Schottelius, 05/21/2020 05:02 PM

1 1 Nico Schottelius
h1. How to configure Arista switches
2
3 3 Nico Schottelius
{{toc}}
4
5
h2. Saving your changes
6
7
If you don't enter write at the end, everything is lost after reboot.
8
9
<pre>
10
write
11
</pre>
12
13 1 Nico Schottelius
h2. Entering conf mode
14
15
<pre>
16
enable
17
conf
18
</pre>
19
20
h2. Setting password
21
22
<pre>
23
username admin secret <passwordhere>
24
</pre>
25
26
h2. Setting name
27
28
<pre>
29
hostname <NAME>
30
</pre>
31
32 13 Nico Schottelius
By default set it to *switch-placeX*. While the placeX part is indeed redundant, it is necessary to be able to distinguish switch1.place5 and switch1.place6.
33
34
35 1 Nico Schottelius
h2. Creating a VLAN
36
37
<pre>
38
vlan <ID-OF-VLAN>
39
name <NAME-OF-VLAN>
40
</pre>
41
42 2 Nico Schottelius
h2. Putting a port into a untagged vlan
43 1 Nico Schottelius
44 2 Nico Schottelius
<pre>
45
interface EthernetXX
46
   switchport access vlan YY
47
</pre>
48
49 1 Nico Schottelius
h2. Creating a port channel (= LACP = bonding)
50 2 Nico Schottelius
51
* go to the interface that you want to be in the port-channel
52
* configure it
53
54
<pre>
55
interface EthernetXX
56
   channel-group XX mode active
57
</pre>
58 4 Nico Schottelius
59 10 Nico Schottelius
h2. Creating a port channel over multiple switches using MLAG
60
61
<pre>
62
interface EthernetXX
63
   channel-group XX mode active
64 12 ll nu
interface port-channel XX
65 10 Nico Schottelius
   mlag XX
66 11 ll nu
67 10 Nico Schottelius
</pre>
68
69
And if you want to have tagged/trunk port:
70
71
<pre>
72
   switchport mode trunk 
73
</pre>
74
75 4 Nico Schottelius
h2. Upgrading a switch
76
77
* copy the image from usb to flash
78 1 Nico Schottelius
* change the boot config
79 5 Nico Schottelius
* don't forget to write
80 4 Nico Schottelius
* reload
81
82
<pre>
83
copy usb1:/EOS-4.14.4.swi flash:/EOS-4.14.4.swi
84
configure terminal
85
boot system flash:/EOS-4.14.4.swi
86
show boot-config
87
write
88
reload
89
</pre>
90 6 Nico Schottelius
91
h2. Configuring MLAG
92
93
* Create a port channel for communication
94
* Configure the mlag over it
95 7 Nico Schottelius
* Assuming the switches are connected by ethernet 47 and ethernet 48
96
* Assuming that the switches use vlan 13
97
* ZZ = ip suffix of the switch
98
* WW = ip suffix of the other switch
99
* mlagdomain = something local
100 6 Nico Schottelius
101
102
<pre>
103 7 Nico Schottelius
interface ethernet 47
104
    channel-group 47 mode active
105
106
interface ethernet 48
107
    channel-group 47 mode active
108
109 9 Nico Schottelius
interface Port-Channel47
110
   switchport mode trunk
111
   switchport trunk group mlag-aristas
112
113 7 Nico Schottelius
vlan 13
114
   name mlag-aristas
115
   trunk group mlag-aristas
116
117
interface Vlan13
118
   no autostate
119
   ip address 10.3.4.ZZ/24
120
121
122 1 Nico Schottelius
mlag configuration
123
   domain-id MLAGLOCALDOMAIN
124
   peer-address 10.3.4.WW
125 8 Nico Schottelius
   local-interface Vlan13
126 1 Nico Schottelius
   peer-link Port-Channel47
127 8 Nico Schottelius
128 6 Nico Schottelius
129
</pre>
130
131
h2. Configuring BGP
132
133
* XX = ip suffix
134
135
<pre>
136
router bgp 209898
137
   router-id 0.0.0.XX
138
   bgp default ipv6-unicast
139
   maximum-paths 4
140
   bgp listen range 2a0a:e5c0:1:8::/64 peer-group ungleich remote-as 209898
141
   neighbor ungleich peer-group
142
   neighbor ungleich maximum-routes 12000 
143 1 Nico Schottelius
</pre>