Project

General

Profile

How to configure Arista switches » History » Version 15

Nico Schottelius, 01/17/2022 10:36 PM

1 1 Nico Schottelius
h1. How to configure Arista switches
2
3 3 Nico Schottelius
{{toc}}
4
5
h2. Saving your changes
6
7
If you don't enter write at the end, everything is lost after reboot.
8
9
<pre>
10
write
11
</pre>
12
13 1 Nico Schottelius
h2. Entering conf mode
14
15
<pre>
16
enable
17
conf
18
</pre>
19
20
h2. Setting password
21
22
<pre>
23
username admin secret <passwordhere>
24
</pre>
25
26
h2. Setting name
27
28
<pre>
29
hostname <NAME>
30
</pre>
31
32 13 Nico Schottelius
By default set it to *switch-placeX*. While the placeX part is indeed redundant, it is necessary to be able to distinguish switch1.place5 and switch1.place6.
33
34
35 1 Nico Schottelius
h2. Creating a VLAN
36
37
<pre>
38
vlan <ID-OF-VLAN>
39
name <NAME-OF-VLAN>
40
</pre>
41
42 2 Nico Schottelius
h2. Putting a port into a untagged vlan
43 1 Nico Schottelius
44 2 Nico Schottelius
<pre>
45
interface EthernetXX
46
   switchport access vlan YY
47
</pre>
48
49 1 Nico Schottelius
h2. Creating a port channel (= LACP = bonding)
50 2 Nico Schottelius
51
* go to the interface that you want to be in the port-channel
52
* configure it
53
54
<pre>
55
interface EthernetXX
56
   channel-group XX mode active
57
</pre>
58 4 Nico Schottelius
59 10 Nico Schottelius
h2. Creating a port channel over multiple switches using MLAG
60
61
<pre>
62
interface EthernetXX
63
   channel-group XX mode active
64 12 ll nu
interface port-channel XX
65 10 Nico Schottelius
   mlag XX
66 11 ll nu
67 10 Nico Schottelius
</pre>
68
69
And if you want to have tagged/trunk port:
70
71
<pre>
72
   switchport mode trunk 
73
</pre>
74
75 14 Dominique Roux
If you want to have untagged connections to be automatically tagged:
76
77
<pre>
78
switchport trunk native vlan <VLAN>
79
</pre>
80
81
If you want to allow fallback of lacp:
82
83
<pre>
84
port-channel lacp fallback static
85
port-channel lacp fallback timeout 20
86
</pre>
87
88 4 Nico Schottelius
h2. Upgrading a switch
89
90
* copy the image from usb to flash
91 1 Nico Schottelius
* change the boot config
92 5 Nico Schottelius
* don't forget to write
93 4 Nico Schottelius
* reload
94
95
<pre>
96
copy usb1:/EOS-4.14.4.swi flash:/EOS-4.14.4.swi
97
configure terminal
98
boot system flash:/EOS-4.14.4.swi
99
show boot-config
100
write
101
reload
102
</pre>
103 6 Nico Schottelius
104
h2. Configuring MLAG
105
106
* Create a port channel for communication
107
* Configure the mlag over it
108 7 Nico Schottelius
* Assuming the switches are connected by ethernet 47 and ethernet 48
109
* Assuming that the switches use vlan 13
110
* ZZ = ip suffix of the switch
111
* WW = ip suffix of the other switch
112
* mlagdomain = something local
113 6 Nico Schottelius
114
115
<pre>
116 7 Nico Schottelius
interface ethernet 47
117
    channel-group 47 mode active
118
119
interface ethernet 48
120
    channel-group 47 mode active
121
122 9 Nico Schottelius
interface Port-Channel47
123
   switchport mode trunk
124
   switchport trunk group mlag-aristas
125
126 7 Nico Schottelius
vlan 13
127
   name mlag-aristas
128
   trunk group mlag-aristas
129
130
interface Vlan13
131
   no autostate
132
   ip address 10.3.4.ZZ/24
133
134
135 1 Nico Schottelius
mlag configuration
136
   domain-id MLAGLOCALDOMAIN
137
   peer-address 10.3.4.WW
138 8 Nico Schottelius
   local-interface Vlan13
139 1 Nico Schottelius
   peer-link Port-Channel47
140 8 Nico Schottelius
141 6 Nico Schottelius
142
</pre>
143
144 15 Nico Schottelius
h2. Combining (MLAG+nolacp) + (Trunk+untagged vlan fallback)
145
146
* Allow servers to netboot
147
* Without LACP active
148
* Without VLAN tagging active
149
150
Configuration valid for both switches:
151
152
<pre>
153
interface Port-Channel1
154
   switchport trunk native vlan 10
155
   switchport mode trunk
156
   port-channel lacp fallback static
157
   port-channel lacp fallback timeout 20
158
   mlag 1
159
!
160
interface Ethernet1
161
   channel-group 1 mode active
162
163
</pre>
164
165
166
167 6 Nico Schottelius
h2. Configuring BGP
168
169
* XX = ip suffix
170
171
<pre>
172
router bgp 209898
173
   router-id 0.0.0.XX
174
   bgp default ipv6-unicast
175
   maximum-paths 4
176
   bgp listen range 2a0a:e5c0:1:8::/64 peer-group ungleich remote-as 209898
177
   neighbor ungleich peer-group
178
   neighbor ungleich maximum-routes 12000 
179 1 Nico Schottelius
</pre>